Monitoring
We've processed the backlog of jobs and are continuing to monitor
Identified
Our risk processing system is experiencing an new issue where risk reviews are slow to complete, which is resulting in 12 hour delays in risk processing. We're working on resolving this right now.