Resolved
Third party service error rates have dropped and risk review, and chat are back to expected service times.
Investigating
Risk review and chat features are experiencing slower response times due to third-party service limits. Tasks may be delayed or require retry. We are actively monitoring.