Resolved
Contract review pipeline is fully operational again
Monitoring
We've deployed changes are now monitoring risks queue for return to normal
Investigating
We've rolling out a fix for the processing of risk review items, currently we are seeing slow resolution. We'll have a update in the next 30 min